- Checkout Slowness Due to Shopify API Latency – Incident details

All systems operational

Checkout Slowness Due to Shopify API Latency

Resolved
Degraded performance
Started 2 months agoLasted 14 minutes

Affected

Checkout Service

Degraded performance from 12:25 PM to 12:39 PM

External Services

Degraded performance from 12:25 PM to 12:39 PM

Updates
  • Resolved
    Resolved

    Resolution

    Shopify API response times have stabilized and remained normal after continued monitoring.

    All checkout flows and order placements are now fully operational and performing as expected.


    Impact Summary

    • A subset of stores experienced checkout slowness

    • Other Shopflo features remained unaffected

    • No data loss or order inconsistencies occurred

    Post-Incident Actions

    • Continued monitoring of Shopify API dependencies

    • Strengthening safeguards for upstream latency spikes

    • Improving early detection and alerting mechanisms

  • Monitoring
    Monitoring

    Shopify API response times have returned to normal levels.

    Checkout performance has improved, and order placements are processing as expected. We are continuing to closely monitor the system to ensure stability before marking this incident as fully resolved.

  • Investigating
    Investigating

    What’s Happening

    We are again observing checkout slowness and delayed order placements for some stores.

    Initial signals indicate elevated latency from Shopify APIs involved in order placement and validation, which is impacting real-time checkout flows.


    Impact

    • Checkout pages may load slower than usual

    • Order placement may take longer to complete

    • Other Shopflo functionalities continue to work as expected

    • Impact is limited to a subset of stores

    Current Status

    • Engineering teams are actively investigating

    • Shopify API performance is being closely monitored

    • Safeguards and retries are in place to reduce failures

    Next Update

    We’ll share an update as soon as the cause is confirmed or if there’s a change in impact.