- Degraded Performance on Shopflo Checkout due to Shopify Slowness – Incident details

All systems operational

Degraded Performance on Shopflo Checkout due to Shopify Slowness

Resolved
Degraded performance
Started about 2 months agoLasted 37 minutes

Affected

Third Party: Shopify → Shopify API & Mobile

Degraded performance from 9:20 AM to 9:50 AM, Operational from 9:50 AM to 12:00 AM

Checkout Service

Degraded performance from 9:20 AM to 9:50 AM, Operational from 9:50 AM to 9:57 AM

Discount Service

Degraded performance from 9:20 AM to 9:50 AM, Operational from 9:50 AM to 9:57 AM

Updates
  • Resolved
    Resolved

    Update:

    The issue caused by Shopify API slowness has been fully resolved. Shopflo Checkout is operating normally and order placement speeds are back to expected levels.

    After thorough monitoring, we can confirm system stability and no further impact is observed.

  • Monitoring
    Monitoring

    Update:

    The Shopify API performance has recovered and Shopflo Checkout is now functioning normally. Order placement and all checkout flows are back to expected speeds.

    We are currently monitoring the system closely to ensure stability and to confirm there is no further degradation.

    Next Update:

    We will mark this incident as Resolved after a short period of stable monitoring.

  • Investigating
    Investigating

    Description:

    We are experiencing overall slowness on Shopflo Checkout because Shopify’s APIs are currently responding slowly. Since Shopflo Checkout relies on Shopify for multiple operations, this is impacting the performance of the entire checkout flow.

    Impact:

    • Order placement is slow

    • Checkout loading times may be higher than usual

    • All Shopify-dependent actions may feel delayed

    Root Cause:

    Slowness in Shopify’s downstream APIs.

    Updates:

    Our team is actively monitoring the situation and coordinating based on Shopify’s API performance. We will share updates as soon as there is any improvement or confirmation from Shopify.

    Note:

    This is a Shopify-side performance issue; Shopflo systems are operating as expected.