- Degraded Performance on Shopflo Checkout Due to Shopify API Slowness – Incident details

All systems operational

Degraded Performance on Shopflo Checkout Due to Shopify API Slowness

Resolved
Degraded performance
Started about 2 months agoLasted 20 minutes
Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring

    Update (1:12 PM):

    Shopflo Checkout performance is back to normal. Order placement and all checkout flows are working as expected.

    We are actively monitoring the system to ensure stability and to confirm there is no further degradation before marking the incident as Resolved.

  • Investigating
    Investigating

    Description:

    We are observing a fresh incident where Shopflo Checkout is experiencing overall slowness. This is due to degraded performance in Shopify’s APIs, which are impacting all Shopify-dependent operations in the checkout flow.

    Impact:

    • Checkout loading is slow

    • Order placement is delayed

    • All Shopify-related actions may take longer than usual

    Root Cause:

    Suspected slowness in Shopify’s downstream APIs.

    Updates:

    Our team is actively investigating and monitoring Shopify API performance. We will share updates as soon as we have more clarity or once the situation improves.