- Incident: Discount Application Issues – Incident details

All systems operational

Incident: Discount Application Issues

Resolved
Degraded performance
Started about 1 month agoLasted about 1 hour

Affected

Discount Service

Operational from 11:30 AM to 12:39 PM, Degraded performance from 12:39 PM to 12:44 PM

Updates
  • Postmortem
    Postmortem

    Postmortem: Discounts Temporarily Unavailable

    Incident Summary

    On 10th Feb 2026 5:01pm, discounts were temporarily unavailable during checkout. This action was taken to prevent a cascading impact on checkout and dependent services after an internal issue was detected in the discounts system. Disabling discounts ensured that checkout and other critical services continued to operate reliably without broader service disruption

    Customer Impact

    • Discount codes could not be applied for a limited period of time

    • Checkout continued to work normally without discounts

    • No orders failed or were lost during this window

    What Happened

    A database index used by the discounts system became corrupted, which caused discount evaluations to fail safety thresholds.

    To protect the checkout experience, discounts were automatically disabled. This ensured that checkout remained stable while the issue was investigated and resolved.

    Timeline

    • T0: Internal alerts detected failures in the discounts system

    • T0: Discounts automatically disabled to protect checkout and dependent services

    • T0 + 2 minutes: Root cause identified as database index corruption

    • T0 + 5 minutes: Index rebuild process started immediately

    • T0 + ~1 hour: Index rebuild completed (extended due to large number of discounts)

    • T0 + ~1 hour: Discounts re-enabled after system health verification

    Resolution

    • Discounts were temporarily turned off to maintain checkout reliability

    • The affected database indexes were rebuilt

    • Due to the large number (more than 1B+) of discounts, this process took approximately 1 hour

    • Once the rebuild completed and systems were verified as healthy, discounts were restored

    Prevention Going Forward

    We are taking steps to reduce the likelihood and impact of similar issues by:

    • Periodic monitoring around discount system and database index health

    • Adding earlier alerts before safety thresholds are reached

    • Optimising index maintenance and recovery procedures

    We apologise for the inconvenience and appreciate your patience while we worked to restore full functionality.

  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring
    We implemented a fix and are currently monitoring the result.
  • Investigating
    Investigating

    We are currently investigating an issue where discounts are not being applied correctly during checkout for users. Other checkout functionalities continue to work as expected.