- Payment Gateway Degradation (EaseBuzz) – Incident details

All systems operational

Payment Gateway Degradation (EaseBuzz)

Resolved
Major outage
Started about 1 month agoLasted 37 minutes

Affected

Payment gateways

Major outage from 2:27 PM to 3:04 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified

    We are currently investigating an issue with EaseBuzz Payment Gateway.

    • Some transactions are experiencing failures or delays.

    • Merchants with an alternate payment gateway configured are seeing successful checkouts via fallback.

    • Others may experience partial service disruption during checkout.