- Temporary checkout degradation during database upgrade – Incident details

All systems operational

Temporary checkout degradation during database upgrade

Resolved
Major outage
Started 2 months agoLasted 43 minutes

Affected

Checkout Service

Major outage from 7:26 AM to 8:10 AM

Updates
  • Resolved
    Resolved

    Resolved: Checkout systems stable following database upgrade

    The database upgrade and restart process were completed successfully, and checkout systems have been fully operational since 1:20 PM.

    We have continued monitoring the database and overall checkout performance for some time following the maintenance, and all systems are looking stable. With services functioning normally, we are now marking this incident as resolved.

  • Monitoring
    Monitoring

    Update: Database upgrade and restart completed

    The database upgrade and restart process have been successfully completed, and checkout is now fully functional.

    Services have been restored and are operating normally. Our team is continuing to monitor performance closely to ensure stability following the upgrade.

  • Investigating
    Investigating

    We are currently addressing a degradation in database performance and are restarting the database on an upgraded version to improve overall stability and performance.

    During this maintenance window, the checkout service may experience temporary degradation for a couple of minutes. To minimize impact, checkouts during this period will fall back to a redirection to Shopify Checkout.

    Our team is actively managing this process and we expect normal performance to resume shortly. Further updates will be shared as progress continues.